Jump to content

Mark all as read

Photo

My First R/c Buggy...


8 replies to this topic

#1 MAD RACER

MAD RACER

    Member

  • Members
  • PipPipPip
  • 1181 posts
  • Gender:Male
  • Location:Australia

Posted 01 June 2010 - 02:35 AM

Now being a vintage collector for the past 2yrs and having nearly 40 in my collection. All but 5 are runners i now bought the same buggy that kicked my r/c habbit in.

It's the Mauri Galaxy with red roll cage and 550 racing motor.

It's had stuff all use and got it for $130 A.U.

Can't wait till i get and rebuild it. It will be run at our big vintage meets here along with Capt Splats Blue cage Galaxy.
Vintage all the way!!!!!!

#2 zakspeed

zakspeed

    Member

  • Members
  • PipPipPip
  • 390 posts
  • Gender:Male
  • Location:1604

Posted 02 June 2010 - 06:56 PM

Excellant - post some pics when you get it, i've been running my Hunter and it is definatly one of my faves in the Marui line up

#3 MAD RACER

MAD RACER

    Member

  • Members
  • PipPipPip
  • 1181 posts
  • Gender:Male
  • Location:Australia

Posted 17 January 2011 - 10:47 AM

Excellant - post some pics when you get it, i've been running my Hunter and it is definatly one of my faves in the Marui line up



Hers a pic of it . Sorry it took so long.

Posted Image
Vintage all the way!!!!!!

#4 zakspeed

zakspeed

    Member

  • Members
  • PipPipPip
  • 390 posts
  • Gender:Male
  • Location:1604

Posted 18 January 2011 - 08:43 PM

Hers a pic of it . Sorry it took so long.


excellant, do you plan to run it ? i've still not finished my Hunter project .. If you need any spares let me know, I've still some left but not much

#5 MAD RACER

MAD RACER

    Member

  • Members
  • PipPipPip
  • 1181 posts
  • Gender:Male
  • Location:Australia

Posted 18 January 2011 - 10:55 PM

Hi Zakspeed.

I DO need a spare idler gear as well as the little plastic idler shaft retainer. Uses two screws to push the shaft in the groove. Mine is missing.

Once i get these i will be running it.

Can't wait.

Any help much appreciated Tell me if you want some $$$$

Cheers.

Mark
Vintage all the way!!!!!!

#6 fristajlo

fristajlo

    Member

  • Members
  • PipPipPip
  • 205 posts
  • Gender:Male
  • Location:Stockholm, Sweden

Posted 20 January 2011 - 04:53 PM

excellant, do you plan to run it ? i've still not finished my Hunter project .. If you need any spares let me know, I've still some left but not much


Hi zakspeed. Sent you a message.

@Mad racer: sorry for borrowing your thread

#7 Zipster

Zipster

    Newbie

  • Members
  • Pip
  • 9 posts

Posted 01 February 2011 - 05:59 PM

Looks good! I just picked up a hunter (which was my first RC buggy!) and am starting to gather pieces to make it the way I had it back then (not quite stock). My plan is to recreate the mods I did as a kid - Galaxy rear suspension, and somehow at the time I managed to come up with some tiny oil dampers that fit in the inboard system the Hunter used, as well as some RC10 turnbuckle chassis braces to address the cracking issues. If I can't find the equivalent tiny shocks, I may go with an earlier front mod, which Galaxy stuff. Plan is to mostly shelf it, but run at the vintage nationals this fall in the "classics" class.

As I recall, the Hunter/Galaxy could easily hold it's own against the Frogs, etc... but tended to be a bit fragile, especially the chassis.

Anyway, looks good, and always fun to revisit that first car.

#8 MAD RACER

MAD RACER

    Member

  • Members
  • PipPipPip
  • 1181 posts
  • Gender:Male
  • Location:Australia

Posted 07 March 2011 - 05:16 PM

I ran my Galaxy pretty hard for at least 1 whole yr. It had a Hot le mans motor in it too never broke the chassis or anything else for that mater.

I did go through lots of idler gears though and the Speed controller was garbage. I ended up putting in a esc.

The shocks were better than the Hunter i think. The Hunter used a big rear mono shock and i saw there was problems at the pivot points.

What were you breaking in chassis wise????

Cheers.
Mark
Vintage all the way!!!!!!

#9 ships

ships

    Newbie

  • Members
  • Pip
  • 76 posts

Posted 12 March 2011 - 12:39 PM

just finished getting my galaxy rs ready for running again, using a tamiya esc although the original mech speedo works fine, just got a few cracks in the chassis though, anyone got one a good chassis for sale?



Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users