Jump to content

kentphil

Members
  • Content Count

    9
  • Joined

  • Last visited

Community Reputation

2 Neutral

About kentphil

  • Rank
    Newbie

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. https://www.modelsport.co.uk/hobbywing-quicrun-1060-brushed-waterproof-esc-sbec/rc-car-products/404964
  2. I had similar problem to you in that my receiver seemed to have no power from the Tamiya esc. The manual is a nightmare to understand. Changed to a Hobbywing 1060 and had no problems so far.
  3. No, nothing unusal. The servo went a bit crazy, moving on its own. Then I could get no power to the reciever. ive changed to a Quicrun 1060 esc and all ok now.
  4. Recenly got a Savox 0254mg servo. Much better than my previous one. Worth the £20.
  5. It was the esc that was the problem.
  6. A similar thing happened to me. My Tble-02 acted strangely then wouldn't work. I've changed to a Quicrun 1060. Instructions to the Tble-02 are a nightmare too.
  7. Many thanks for your advice. What you say would seem to be right. The receiver seems to dead. I will try and get one from my nearest model shop and hope that fixes it and I can get my Sand Viper running again.
  8. My servo went a bit crazy, moving on its own. Now my esc (TBLE-02) has a flashing red light and beeps. There is no power to the receiver (Abisma) either. Is the Esc now dead? Ive tried resetting it, but still the flashing red light and beeping. Will buying a new esc fix this or is there anything else I can try? I just don't want to buy new parts if I don't need to.
  9. After discovering my Vanquish in a bit of a sorry state in my parents loft, and selling it on ebay for good money I have invested in a Sand Viper + new radio gear. I'ts hopefully coming tomorrow and can't wait to build it. After much investigation I went for the Sand Viper as it's on the dt02 chassis and fully ball raced with metal drive shafts. .
×
×
  • Create New...