Jump to content

Search the Community

Showing results for tags 'damaged'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Tamiyaclub.com Forums
    • General discussions
    • Vintage Tamiya Discussion
    • Re-Release Discussions
    • Tamiyaclub News
    • Tamiyaclub Rules and Site Usage
    • Build Tips and Techniques
    • Monster Trucks, 4x4, Wheelie Rigs and Crawlers
    • Big Rigs and Scale Armour
    • All things RC Nitro
    • The Builds
    • TC Designs...
    • All things electric...
    • RC Racing Talk
    • Meetings & Events
    • Sales, trades & wanted
    • Off-Site sales plugs, tips & gossip - Including eBay, Gumtree etc.
    • Related sites
    • Suspicious Traders
  • Tamiyaclub Sponsors Forum
    • FusionHobbies.com
    • Stellamodels
    • Time Tunnel Models
    • Tamico.de
  • Other makes of RC model...
    • Kyosho
    • Marui
    • Nikko
    • Other makes
  • tcPhotos.com
    • About tcPhotos.com
  • The Outside World
    • Anything not RC related goes here

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


TC Subscriber

Found 1 result

  1. Hi, finished building my M05 only to have a play on the drive and try to jump a small speed-hump and shearing off the front-right hand side suspension mount. When I say small I wasn't being too ambitious, it was about 10cm tall, if that. I've tried epoxy, it worked until I stupidly tried the same thing (I'll never learn), should I fix it the same way again and just not attempt jumps or is there a way of reinforcing the mounts so they don't break again? Thanks Adam
×
×
  • Create New...