Search the Community

Showing results for tags 'drive shafts'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Tamiyaclub.com Forums
    • General discussions
    • Vintage Tamiya Discussion
    • Re-Release Discussions
    • Tamiyaclub News
    • Tamiyaclub Rules and Site Usage
    • Monster Trucks, 4x4, Wheelie Rigs and Crawlers
    • Big Rigs and Scale Armour
    • The Builds
    • TC Designs...
    • All things electric...
    • RC Racing Talk
    • Meetings & Events
    • Sales, trades & wanted
    • Off-Site sales plugs, tips & gossip - Including eBay, Gumtree etc.
    • Related sites
    • Suspicious Traders
  • Tamiyaclub Sponsors Forum
    • FusionHobbies.com
    • Stellamodels
    • Time Tunnel Models
    • Tamico.de
  • Other makes of RC model...
    • Kyosho
    • Marui
    • Nikko
    • Other makes
  • tcPhotos.com
    • About tcPhotos.com
  • The Outside World
    • Anything not RC related goes here

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 1 result

  1. I hope someone can help. I thought I'd upgrade my old fox drive shafts with the new novafox dog bones and drives cups. Now, I've built and rebuilt a few foxes in my time and never had a problem. So this one has me scratching my head. When I put it together, with nice tight screws, the diff ends up being locked. So I loosened the gearbox screws a bit, and it improved slightly, but not much. I've downloaded the novafox manual, and There's nothing different in the set up, so I'm not missing a part. I've put a new gear set in, and it's sill the same. The only thing i think it can be is the old gearbox casing!? Has anyone else come across this issue? Help, I don't know what I'm doing wrong.