Search the Community

Showing results for tags 'tb03'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Tamiyaclub.com Forums
    • General discussions
    • Vintage Tamiya Discussion
    • Re-Release Discussions
    • Tamiyaclub News
    • Tamiyaclub Rules and Site Usage
    • Monster Trucks, 4x4, Wheelie Rigs and Crawlers
    • Big Rigs and Scale Armour
    • The Builds
    • TC Designs...
    • All things electric...
    • RC Racing Talk
    • Meetings & Events
    • Sales, trades & wanted
    • Off-Site sales plugs, tips & gossip - Including eBay, Gumtree etc.
    • Related sites
    • Suspicious Traders
  • Tamiyaclub Sponsors Forum
    • FusionHobbies.com
    • Stellamodels
    • Time Tunnel Models
    • Tamico.de
  • Other makes of RC model...
    • Kyosho
    • Marui
    • Nikko
    • Other makes
  • tcPhotos.com
    • About tcPhotos.com
  • The Outside World
    • Anything not RC related goes here

Calendars

  • Community Calendar

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 2 results

  1. Hi All, Having a clear out and have the random following parts for sale. They are all new and in sealed packs. Below prices include postage to UK and money sent via PayPal friends and family. Happy to post elsewhere for additional cost. Tamiya TA06 Cross Shaft 54331 - £7 Tamiya TB04 Aluminum Cup Joints 54543 - £11 Tamiya Touring Car Wing 54458 - £6.75 Tamiya TT-02 Type-S Aluminum Upper Arm Mount 54652 - £12 TB-03 Aluminum Suspension Mount (1D) 54072 - £8.50 4mm Aluminum Flange Lock Nuts 53024 - £10.50 Please let me know if interested. Mark
  2. Nagakura San

    TB-03RA drive problem...

    Hello, glad to be a part of the community. I’ve almost finished my first Tamiya project in years and I’m having a problem with drive issues. I bought a super cheap but very clean used TB-03D to do a rally conversion (rally block tires and wheels, EVO III WRC body). I’m running a stock gearing of 64t Spur and 23t .06M pinion. I believe the previous owner installed a one way spool in the front because the car basically has FWD only and zero reverse. I get no wheel spin in the rear. I assume I have to tighten something in the diff or the drive shaft/spur, but no idea as this is my first Tamiya build in over 10 years. Any help/tips? Link to a short YouTube video of the problem: