Jump to content
^Smith^

Neo Scorcher - TT-02B Rear Drive Issue

Recommended Posts

Good Day All...

Need some help, please.

It seems that the drive axles aren't long enough or the "cups" that hold the axles aren't deep enough?

The axles, when you drive pop out of the of the "cups".

I stiffened the damper some in the hope that would fix the problem...still doesn't seem to improve. Any thought would be much appreciated !

-smith

TT-02B Rear.jpg

Share this post


Link to post
Share on other sites

Yeah, sure they could be...never thought of that , I'll have to check it, Thanks

Share this post


Link to post
Share on other sites

If they are longer, DF-02 dogbones might solve your issue. They are a little longer than the standard TT-02BĀ ones, and also feature the larger ends which allow them to be used with TT-02B outdrives and axles. You can get standard steel ones or aftermarket alloy. I use the latter on mine.

  • Thanks 1

Share this post


Link to post
Share on other sites

How deep into the wheel axle cups do the dogbones go? If they go deep and there is enough material to them then you could add in o-rings to push the dogbones more into the diff cups.

Share this post


Link to post
Share on other sites

As fas as I recall, the TT02B comes with plastic drive cups that are bigger, and suited to run with the plastic dogbones. Your TT02B seems to have metal drive cups; perhaps you could just upgrade to metal CVDs and that would fix your issue?

Share this post


Link to post
Share on other sites

Thanks everyone for weighing in on my problem!

I have a several fixes now. I'm out of town now, but will employ these repairs when I get home.

thanks again

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...