Sign in to follow this  
Mokei Kagaku

Extremely sticky, glossy and moist tires in Dynahead kit?

Recommended Posts

I didn't receive my Dynahead before yesterday as I've been waiting for a good deal. The good news is that I paid just EUR204 for it and received it yesterday, NIB and with Tamiya distributor shrink wrapping. In other words, the inside of the kit was virtually or literally untouched after leaving Tamiya.

However, when preparing the parts for assembly, I noticed that all six tires are extremely sticky, glossy and moist and have flat spots. Anyone else experienced this?  I've never experienced tires as extreme as this from Tamiya and no other brand either for that sake!

Share this post


Link to post
Share on other sites

Is this not just the mould release coating - have you tried washing them in soapy water to see if it removes it? Ive had tyres before that felt really oily to touch but were fine when washed in fairy liquid.

Not sure about flat spots though.

Share this post


Link to post
Share on other sites
2 minutes ago, Superluminal said:

Is this not just the mould release coating - have you tried washing them in soapy water to see if it removes it? Ive had tyres before that felt really oily to touch but were fine when washed in fairy liquid.

Not sure about flat spots though.

I too believe it is mould release agent, but I've never seen that remotely as extreme as on these tires. I intend to try washing it off, but not before I've made photos. If the flat spots are related to this in anyway, I don't know, but at least the tires were packaged correctly in the kit, so the flat spots most likely weren't caused by static load in the packaging.

Share this post


Link to post
Share on other sites

It could be solvents leaching out of the rubber. You see this a lot in 1970's electronics, the power cables become shiney, sticky and moist.

The flat spots reinforce the idea as the solvents wouldn't leach out equally from all parts of the tyres.

Seems odd for it to be happening to a reasonably new kit.

Share this post


Link to post
Share on other sites

My tyres for my dynahead were 'normal', no sticky , no release agent

Has anyone the part number for the foam inserts (which have been removed on the dynahead!)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this