Jump to content
Sign in to follow this  
Lucero

Help with Tamiya Hi Torque Server Saver

Recommended Posts

So yeah. It's arrived. Now what :D

Do I still use the horn from the kit, because it doesn't "click in". 

I've put the two brass rings together, and the outer ring over them, and clicked them into the servo Tamiya/Futaba gear. Not sure if that's right or not. 

The kit one sort of all clicks together nicely using Q4, the Q3 plastic ring (which I think is the plastic version of the metal rings in the 5100 kit) and then JJ10, the horn. 

Any ideas?

Share this post


Link to post
Share on other sites
16 minutes ago, Lucero said:

Do I still use the horn from the kit, because it doesn't "click in". 

No, you use one of the two that come with the hi-torque servo saver, which may not exactly match the kit one in terms of size, but I've never had a problem with the kits I've used them on. 

Share this post


Link to post
Share on other sites
3 minutes ago, rich_f said:

No, you use one of the two that come with the hi-torque servo saver, which may not exactly match the kit one in terms of size, but I've never had a problem with the kits I've used them on. 

Excellent, thanks. There's a long and a short, and the long is pretty much the same as the JJ part from the kit.

Thanks. 

Also looks like I'm going to have to lengthen the motor wires that came with the HobbyWing Justock combo. This is starting to become a faff :(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...