Model: (Click to see more) 99996: Radio Gear
Status: How To Guide
Date: 16-Dec-2009
Comments: 16
Share this model:

Recently I've posted my Eurgle 2.4ghz 3channel radioset here, and had a big problem with it. Model memory 2 to 8 didn't work properly. Now, with the help of Stormbos from Tamiyagekken.nl, they work :D The problem is that the ARC for the steering and throttle are set up wrong from the factory. They have 025 050 075 100 000 values (in this order) while they should be 000 025 050 075 100. Sounds logic afterwards, but it is hard to find because the menu isn't very clear on this. So for everyone having the same problem as I had, try this and it will work :) Thanks Stormbos!


Comments

*Topcat*

16-Dec-2009

I have exactly the same problem but what you just said makes absolutley no sense to someone with a brain like mine please explain so that i can understand Cheers

Tizer

16-Dec-2009

In the menu, there is the option ARC. Click on that, and you'll see 'CH: ST' and 'CH: TH'. When you click on ST you'll see a graph and four values on the left of the screen. These values are wrong, and you need to set them up as I said above. If you have set all 4 right click enter, do the same for TH and it should work fine again

*Topcat*

16-Dec-2009

just been to try this and i owe you a big thankyou as now it seems like i got a real bargain for what they cost and i can use the other 4 recievers that i got without having to re-trim the different models

jeffy

16-Dec-2009

Thanks in advance as I received 5 more receivers the other day and thought oh my what a waste they are going to be scrap Now I'm happy again as it does work well and a bargain too

Sideways-King

17-Dec-2009

Tizer & Stormbos you have made my Xmas as I had the same problem a shed load of receivers and the annoyance of using Model Memory 1 through out. Thnaks for this post. Merry Christmas

boogyloop

17-Dec-2009

I've seen the receivers for these but never the handsets as i cant find were to get one from, Not got one as yet but thanks in advance for the tip.

Tizer

17-Dec-2009

Glad to help guys Just one thing though... the Aux channel still doesn't work with model 2-8 :S
@Boogy: You can get m at ebay, look for the store named Revolutionshop or Gemstraveller.

Tizer

20-Dec-2009

Aux channel is also fixed. You need to set the right button for the 3rd channel, because the buttons are all messed up too....

BiggusDitchus

29-Dec-2009

Very helpful as I'm looking at getting one of these myself thank you. Can you tell me if the 3rd channel is just on or off or 3 position?

Tizer

29-Dec-2009

I think you can set it to 3 positions aswell. I'm not sure as I haven't tried it yet, but I know you can use the switches and buttons below the screen for the 3rd channel too. I'll try some settings tomorrow and let you know

tamiya_drift_junky

7-Jan-2010

Top notch advice Tizer and Stormbos! I'm about to invest in one of these and a truckload or receivers. As far as value for money, you just can't beat these controllers! THX!!

svibrc

28-Feb-2010

Thanks a lot! I bought this thing with 8 recievers and have been trying to figure out what was wrong. Now it works perfect!!

mini-ac

9-May-2010

dude, thanks so much, I was having big trouble setting up the radio, did not know why it was goiing left than right. thanks thanks thanks

Tizer

9-May-2010

Another thing I have learned from my experience with this transmitter is that you should not be to rough on the steeringwheel. Mine broke on the inside (stupid design flaw!). Can be fixed though. I'll have a go at fixing it this week

cali75

26-May-2010

I just bought one of these from h2. Have you had any other problems or is this a good radioset all around?

Tizer

26-May-2010

if you read my last comment you know about my last findings


Want to leave a comment?